Max buffer won't go lower than 120ms

I bought premium because I wanted to try and reduce the buffer, but whenever I set it below like 105 it says it has been changed to 120ms, which is very annoying.

I thought using USB would change it but it made no difference.

As far as I can see, there are no latency issues apart from the increased buffer, and it’s a bit annoying because I just want to listen to music on my phone and laptop that is properly synced, without having to manually sync it myself by pausing/playing until it’s good enough.

Any reason why this is happening and anything I can do to fix it?

I am not using OpenSL because it sounds like an underwater trash can, and I have request low latency turned off, again because it sounds like an underwater trash can.
Using Wavelet as an equalizer (uninstalling it made no difference).

I am also using Voicemeeter as well, and my PC is Windows 10.
Phone is Galaxy S8 with Android 9.

pls help ty.

Second issue
I use FL Studio, but the audio from that isn’t transmitted with AudioRelay. Any reason why this is? FL Studio also doesn’t show up in Windows 10 Volume Mixer, and the audio from it doesn’t show up when it makes sounds: I don’t see the volume bar go up.


As an aside, is there a way to stream the audio from PC, but to simply just delay the audio sent from PC so that it syncs properly with the phone? i.e. have a set delay/buffer from the PC to account for the time it takes to travel to the phone, so that the phone and PC can sync properly? This is the goal I am trying to achieve, but don’t want to take 1 year to make my own app x). Doesn’t have to be all PC audio, just music from an application like VLC or a browser.

Hey @notmyname74,

Yea, it’s annoying. The interface could be improved to show what’s happening.

Here’s an explanation:

Depending on the device, the AudioTrack output (provided by Android) needs a relatively big internal buffer.
The internal buffer’s size is the minimum amount of latency that the audio will have.

When AudioRelay detects that you set a max buffer that is lower than the
internal buffer, it automatically changes your value. Having a max value lower than a minimum value would make no sense.

To have lower latency and good audio quality, please try this version.

I guess that FL Studio is sending its output to a ASIO device, which isn’t supported by AudioRelay.

Can doing any of the following work for you?

  • If you’re outputting FL Studio to Voicemeeter

    • In Voicemeeter > Hardware out > select the same device as in AudioRelay
  • Otherwise, In FL Studio

    • Options > Audio settings
    • In device, select the one device as in AudioRelay

You could use the high buffer option in AudioRelay and advance the sound by 2 seconds in VLC (via the J and K keys).