So whats going on with the DAC in stuff like the g8?

Using OpenSL or “reduce latency” under audioTrack results in my high impedance headphones not getting the right power it seems? Its not just the EQ, its clearly a power thing but is there any workaround on either end?

I don’t even need the hifi toggle on for a huge difference with just plain audioTrack is the weird part, if I did then this would make a great deal more sense…

Hello,

As written here, requesting a lower latency “path” from the Android system will disable hardware and audio “effects”. Which I assume, is what is causing the difference you’re experiencing.

You didn’t say what the problem was when using AudioTrack + reduce low latency off. I’m guessing that there’s too much latency?

Though, after re-reading the docs above, the SL_ANDROID_PERFORMANCE_LATENCY_EFFECTS seems interesting, I’ll do a few tests.

(made a minor edit)

yea, too much latency without the toggle set, on .12,

latency_effects might do it! Will be glad to test if I remember to pop back by

Hi @Nchi,

I finally got around to make this change.
If you’d like to try it, you can install this version:

The new setting can be found in Audio Output > Open SL ES > Enable audio effects

Please let me know if this helps.

hifi toggle works on audiotrack now

the option Audio Output > Open SL ES > Enable audio effects does not adjust with the toggle either when on or off still but it does seem to sound better through either option, though still noticeably weaker than regular audiotrack with the hifi toggle on

your latency improvements are noticeable though unless its all just my new router lol

That sounds good, thanks for testing!