Unable to install audiorelay on Ubuntu 23.10 due to libflac8 not available

When I hit sudo dpkg -i audiorelay it says that it is unable to install as libflac8 is not available:

(Reading database ... 273547 files and directories currently installed.)
Preparing to unpack audiorelay-0.27.5.deb ...
Unpacking audiorelay (0.27.5-1) ...
dpkg: dependency problems prevent configuration of audiorelay:
 audiorelay depends on libflac8; however:
  Package libflac8 is not installed.

dpkg: error processing package audiorelay (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

And it seems that there is no way to install libflac8 for Ubuntu 23. All the Ubuntu forum answers with downloadable links to libflac8 show up with 404 Not Found. There is a way to at least install it using --ignore-dependencies but it renders the package manager as completely unusable. This is because the audio relay package is installed in an incorrect manner which then doesn’t allow you to install any other package until and unless you completely remove audio relay package.
I am sure that because of libflac8 not being available, it doesn’t sound on the tablet as it should. The sound is very low, and it ends up with emitting white noise for some reason.

$ sudo apt install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 audiorelay : Depends: libflac8 but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Did anyone tackle it so far? If so, how did you do it. And if anyone has any links to libflac8 for installation for Ubuntu 23.10 then kindly share it.

Laptop: Ubuntu 23.10, Dell
AudioRelay 0.27.5-1

I was able to install and download the libflac8 for Ubuntu 22 from:

And then installed audiorelay and so far it has been working alright.
Although I faced one issue where my laptop microphone’s input is getting turned on all the time and sent to the device. The device then starts echoing and goes into an infinite loop.

I’m getting around it by setting the audio output as PulseAudio (if you don’t have it then install it). And I turn on pulse audio and in the input devices tab, I change the microphone to Microphone (unplugged) or headset microphone (unplugged). This disabled the mic and only sends the audio output to the device. Hope this helps out someone who is facing similar issues.