Trouble with Exclusive audio

I’m using Android 12 on a Pixel 6.

When Exclusive audio is on, it disconnects entirely from the server when playing media.
And in a call, it just pauses the audio from the server and automatically resumes once the call is through.

When Exclusive Audio is off, media playing works fine, no interruption, but calls have the same behavior as when Exclusive audio is on.

I’ve added a new option to continue playing during phone calls but it’s not available via the Play Store’s version yet.

You can try it here though:

1 Like

Oh great, didn’t realize there was a new release!
I can’t seem to get it working at all, I get a “Beware, there is no active connection” toast on my Android when connecting to a server. I’ve only tried via tethering. It seems to be disconnecting and reconnecting constantly.
I’ve taken a screen recording.
Thank you btw, this app is a lifesaver!

How do I download older versions of the Windows and Android apps?

Never mind 0.12.4 is on the landing page.

Don’t know if this is useful, but when using 0.12.4 Windows app with 0.22.1 Android app, I get similar behavior as displayed in the screen recording above.

Just tried the opposite as well (new Windows version, old Android version) and got similar results.

Not sure what could cause this, could you please post the logs found at %LocalAppData%\AudioRelay\Logs?

Here ya go

So, the installer from the 0.22 version should have deleted some old dlls found at C:\Program Files (x86)\AudioRelay. In your case, it didn’t. :thinking:

Deleting the whole C:\Program Files (x86)\AudioRelay folder and then reinstalling the 0.22 version should work.

1 Like

I uninstalled the old version, and the seemed to have deleted the directory as well.
Works perfectly now, thank you!

On my device (Pixel 6, Android 12), the audio still pauses during phone calls even with the new setting from 0.22
The phone is rooted. Is there anything I can do to get it working?

You’re right, it doesn’t work on Android 12. A new runtime permission is required which isn’t asked by the app. It’ll be fixed in the next version!

1 Like