USB tethering doesn't work

My phone is plugged to my PC, USB tethering is activated, but in the app it keeps asking me to activate it to use it. If I click on it, it sends me to the settings to activate the tethering, but doing so changes nothing.

When you had go to settings you had activated the tethering? Isn’t in every phone that the app throws you at the right place for do it.

If you successfully activated USB tethering, you simply need to go back to AudioRelay and click on the search button. A new server entry should show up. Clicking on it will use the USB connection.

the app it keeps asking me to activate it to use it

You need to think of this as a shortcut to the settings, as I’m not sure if Android apps can now if you have already activated USB tethering.

It only shows the wifi connection when I click on search again.

Okay, you’ve not mentioned what happens on your PC when you enable it. Do you know whether the PC gets the new connection? There’s maybe an issue on Windows’ side.

Please verify this:

  • In the AudioRelay Server, is there a new IP address displayed?
    • If yes, try to connect manually from the Android app. (via the 3-dots menu in the upper right corner)
  • In the PC’s network settings, is the new connection there?

If there’s a connection but the server doesn’t display the new IP address, could you please copy-paste the result of the ipconfig command?

I actually can only use internet on my PC through USB Tethering, it doesn’t have a Wifi card and I haven’t bought an ethernet cable yet, so yes, the PC is getting the connection, but the AudioRelay app only shows me one option which the IP is the same as the one that shows in ipconfig . Was it supposed to only show me this one option, or should it have an option for each connection?

Then if there’s no other connection, the IP shown is from the USB tethering, right?
What happens when you try to manually enter this IP address in the app?

via the 3-dots menu in the upper right corner

I have the same problem. I use a USB modem, I can use the Internet, but it does not connect to the audio relay. Neither manually, nor using the search

I solved the problem. it was all because of the VPN. Disabled the “invisible LAN port” function

1 Like