There is no audio when call reconnects

Hi,

After the recent update, AudioRelay stops playing PC audio on mobile if I follow this order:

  1. Connect to AudioRelay PC from Mobile (via Wifi/USB Tethering)
  2. Make or Receive a call on mobile

But AudioRelay works fine when I follow this order:

  1. Make or Receive a call on mobile
  2. Connect to AudioRelay PC from Mobile (via Wifi/USB Tethering)

In 2nd case even restarting AudioRelay both on PC and Mobile does not fix the issue.
I have disabled “Exclusive Audio” as well, but still have the same issue.

I am using Android 10 and Windows 10 OS.

Hi @King_DooM,

You’re right, it seems that the system mutes the internal audio player when a call is made…
I’ve tried to implement a fix that goes around this issue, could you please try this version?

You’ll need to go to the new Exclusive audio menu and select Deactivated (Phone call fix).

If you don’t mind, why do you need AudioRelay during calls? Hearing notifications?

Hi,

It still does not fix the issue completely. The only change is when the call ends, the audio resumes. Previously it remained muted even after the call disconnects.

I have tried Exclusive audio > Deactivated as well as Deactivated(Phone call fix). As soon as I dial a number the AudioRelay mutes itself.

I use AudioRelay to transmit Game Audio to my Phone, while I am on call with my friends. In my past experience AudioRelay along with other calling Apps like Whatsapp worked seamlessly, I have not tested the latest version of AudioRelay along with Whatsapp call yet.

Could you please try this version and select the Deactivated (Phone call fix alternative) mode?

Be sure to wait a few seconds before hanging up when testing.

If the stream is not muted when you do this

But AudioRelay works fine when I follow this order:

  1. Make or Receive a call on mobile
  2. Connect to AudioRelay PC from Mobile (via Wifi/USB Tethering)

I don’t see how this version won’t work… :thinking:

What’s your device by the way?

Hi,

It still does not work even with new settings Deactivated (Phone call fix alternative).

During my 20 min call duration, I tried connecting/disconnecting AudioRelay, but PC audio remained muted whole time. As soon as the call ended, PC audio resumed playing.

I tested with Whatsapp call and there was no issue. Both call audio and PC audio worked fine, even though PC audio volume was slightly lower.

I am using Realme C15 Phone.
For calling I am using Phone by Google - Caller ID & Spam Protection

Then there’s nothing to do. :frowning:
If your device wants to mute every app during calls… AudioRelay can’t go against that.

But what did you mean exactly when you wrote that?

But AudioRelay works fine when I follow this order:

  1. Make or Receive a call on mobile
  2. Connect to AudioRelay PC from Mobile (via Wifi/USB Tethering)

Isn’t “working fine” implying that you hear the audio?
Which would mean that you could just reconnect during a phone call.

Yes, If I first make or receive a call and then connect AudioRelay then there is no issue.
The issue arises when I have already connected AudioRelay and then make or receive the call.

I try to Disconnect/Reconnect AudioRelay but it does not fix the issue until the call is disconnected. Even Force Stopping AudioRelay does not fix the issue, once it is muted it stays muted until call is disconnected.

I don’t think it has something to do with my device only otherwise it would not have worked alongside at all in this case(Call 1st and Connect AudioRelay 2nd), maybe when the phone call is initiated it blocks all Background music playing apps(vlc and mx player etc).

*Note:** You can play back the audio data only to the standard output device. Currently, that is the mobile device speaker or a Bluetooth headset. You cannot play sound files in the conversation audio during a call.
https://developer.android.com/guide/topics/media/mediaplayer

Hi,

I don’t think I’ll look further into this, the new methods work on my device and if force stopping the app doesn’t help… I don’t think I can do anything from within the app.

Have you tried to select a different audio output though? (in the app settings)
By any chance, the muting could be affecting only OpenSL or vice-versa.