The TCP communication stopped working (constant reconnects)

The TCP communication to Samsung SM-T350 (192.168.1.187) stopped working. 192.168.1.187 Is my pc’s ip, not my tablet’s.

That’s… quite strange.
Is it a permanent issue on your end or did it ever work? Have you tried to connect other devices by any chance?

i have the same issue.
edit: i fixed it, it was a rookie mistake.
great program! pretty useful.

Hi @Not_Emir,

Could you please post how you fixed it?
It’d be great for future readers. :smiley:

what is the rookie mistake!
The same thing happens to me but with xiaomi

Hey there,

I had the same problem, but I have fixed it.

In my case, this problem happens when the IP address I typed into my Android app is wrong, and that is because I was trying to connect to a PC via a mobile hotspot instead of via a public Wifi. The address shown on the server app, however, is the PC’s IP address in the public Wifi (which my phone is not connected to), and not the IP address in the mobile hotspot.

The problem was solved by simply inputting the IP address found from Control Panel > Network and Sharing Centre > Change Adaptor Settings > double-click {the adaptor that sets up the mobile hotspot, it will only show up when the hotspot is turned on} > Properties, and then the IPv4 address is what I needed.

Also, besides what I did above, I have also found that using the newest update (0.12.4) on my PC will cause the same problem (somehow…), but 0.9.1 works fine.

I am not sure whether this was the ‘rookie mistake’, but I hope this helps.

The server doesn’t show every IP addresses it finds since some of them are pretty useless for our purposes.
I guess it should be tweaked, thanks for the report!

Do you mean that the correct IP address is shown with 0.9.1? Or that you can’t use 0.12.4 at all?