My mic works but it outputs it into my headset

So basically my pc’s audio port got damaged so i am using audio relay to use my headset, as the new mic feature got added, i used it but my problem is even tho my mic works perfectly, the sound gets output in my headset, i saw another post with same issue but that couldnt help me.

Phone:
Android 11
Samsung Galaxy A22 4g
AudioRelay 0.24.2

Laptop:
A desktop with windows 10
AudioRelay 0.24.6

What audio devices have you selected in both the Server and Player screens?

I have my default speaker on server and VB cable input in player, do I need to change something?

No, it’s OK like this.

If you go to sound settings, right click on CABLE Input and then Test, do you hear the test in your headset?

Could you also confirm that the “listen to this device” option isn’t set for CABLE Output?

Yea i do hear it but still if i connect the mic i hear my own voice.

Yea i do hear it

The thing is that you shouldn’t hear it.

(I’m assuming that “listen to this device” is off)

Hypothesis

I’m not sure how plausible it is, but maybe your PC is sending the sound of ALL playback devices to AudioRelay. Your speaker + Cable Input.

Quick recap

Just so that we’re on the same page…

  • Cable Input is a playback device
  • Cable Output is a recording device

When you select Cable Input in the player screen of AudioRelay, the app plays the audio sent from your phone. For Windows and AudioRelay, Cable Input could be simple speaker or headphone.

Experiments

How many playback devices do you have on your PC?

Here’s something your could try

Experiment 1

  • Connect your phone to your PC (don’t start a server on your phone)
  • Go to your PC’s playback devices
  • Right click and press test on all of them.

Do you hear the test in your phone for all of them?
(If everything works as expected, you should hear it only when testing on the device selected in AudioRelay)

Experiment 2

Could you repeat the experiment after selecting another playback device in AudioRelay? (CABLE Input for example)

Potential fix

It seems that someone else had the same issue. (His video demo)
He selected Cable Output in Zoom, and everything is fine first. But as soon as he enables screen sharing, zooms gets whatever comes from Cable Output + whatever sound is played on his computer. (This would include Cable Input)

His fix was to remove Intel Smart Sound Technology drivers and turning off sound reduction in MyAsus.

Do you have either of them?

Hello, I have the same problem, I hear my microphone in my headphones, I tried to delete “Smart Sound Technology” from the device manager but it is not available. Any solution?

Please try this:

  • Connect your phone to your PC (don’t start a server on your phone)
  • Go to your PC’s playback devices
  • Right click and press test on all of them.

Do you hear the sound when you click on all of them or only in the one selected in AudioRelay?

Here’s a video demonstration
(link to the video)

Also, please send a screenshot of the server screen and Windows’ playback device tab.