Constant hiccups and glitches

hi, i have constant hicups and glitches. i tried all settings in audiorelay. i transfer audio from pc to android tablet. it says ofter : ordering not ok, loss ofter more than 0. also on longer breaks, it says trying to reconnect.
pc audiorelay says often: “high latency”.
i tried also soundwire which was really worse. so i dont say that the problem is the software, but maybe you can give me a hint?
i tried even an accesspoint before the rounter, but didnt help.
win7 -> samsung tablet s2 813, Android V9, Lineage CostumRom latest version.
Thanks!

Hello Florian,

How is the CPU usage on the PC?
Could you try to change the power plan to high performance?

But if there’s no improvement even when using a Wifi hotstop, it could
be that one or both of the devices have too weak radios/antennas… :thinking:

Hi Asapha,
thanks!
my cpu is always good. i have an i5 which is right now at around 40%. yes with high perf.

on any glitch there i see that the ordering on android get from ok to not ok.

best regards,
florian

Also what i see is that, the small hickups and glitches cames also when the android latency monitor in the audiorelay app has no big peaks.
but again, than it switches the ordering to not ok.
thanks!

Thanks for the details.

Technically, the app sends the audio over the network using UDP which doesn’t guarantee
that it arrives in the right order…

Right now, out of order packets are dropped by the app, I’ll see what I can do to sort them instead.

Does it happen a lot on your end? (every 2, 10 ,30 secs?)

hi, thanks.
yes happens very often. 2secs, 1,3,4… first i thought it is the router, but than i installed in front of that an acces point TP-Link TL-WR841N N300 WLAN Router (300Mbit/s (2,4GHz), 4 x 10/100Mbit/s]. i disabled dchp for that. everything runs but i still get this constant hicups.
i installed now different 2 wifi cards. the last one is intel advanced 6205. but both same results…

accesspoint settings:
Mode:11bgn mixed
Channel Width:Auto
Channel:Auto
Enable SSID Broadcast
Wireless MAC Filtering: Disabled
Beacon Interval:100 (40-1000)
RTS Threshold:2346 (1-2346)
Fragmentation Threshold:2346 (256-2346)
DTIM Interval:1 (1-15)
Enable Short GI
Enable Client Isolation
Enable WMM

thanks

Hi,
Just tried out your superb app, real life saver.
I too experience hiccups, missing or glitched audio.
Win10, Oxygen OS 10.3.2.
Happened every 2-3sec as op said. After a while tho it seems to stabilize and now only happen minor glitches ~30sec, inbetween has good quality audio.
Latency ~4ms, Late 10, up to 18, loss 0.4 up to 2, ordering ok, buffer varies a lot up to 100ms avg 20.
I did up the hz from 44k to 192khz,.and turned off Bluetooth.
Will test it more.

hey we both have costum roms. i dont think that should maatter, but maybe there is a bit too much optimised at the standbye settinggs?

I’ll soon have new versions that should help with packet loss and ordering issues. It won’t help if there’s high latency though.

It’d be great if you could test them when they’re ready. :grinning:

I think it will fix csibesz07 issues, but Florian’s situation is a bit worse…

Could you please check how it performs if you try to directly connect your devices via tethering? Either by creating a Wifi hotstop or via USB.

Hello @Florian_42, @csibesz07,

Would you mind testing this new version? :slight_smile: