Can't connect to the server from a PC access point

Windows 10 has hot-spon wi-fi access point. Android devise uses this conection for internet and local web. Why AudioRelay app can’t find the server on this pc? App can’t call 192.168.*.1 addresses?

(Edit Asapha: I took the liberty to edit the title)

The app can’t find your server, but have you tried to connect manually? You can do so via the Connect manually available in the upper right corner of the app.

If you did and it’s still not working, could you try to send a ping from your android device to your PC?

My host has ip 192.168.137.1.


Connect manually stops immediately

Lines like these should appear when the ping command works:

Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64

If that’s not the case, it means that your two devices can’t communicate together.
Which means that AudioRelay can’t function. :slightly_frowning_face:

You’re not the only one having this issue it seems… I don’t know if this is normal when sharing a connection from Windows 10…

Could you please return the results of both of these commands? (connect your phone to the hotspot)

  • On your PC, launch cmd.exe from the Windows search bar
  • Type ipconfig

Then

  • On your phone, in the termux app
  • Type ifconfig

After the last update of Windows 10 other applications have lost a stable connection so I think this is a Microsoft bug. Results of ipconfig and ifconfig (I hope it will be understandably on the Russian interface) hotspot config is marked in yellow


Ping PC to Android is high but devices are a couple of meters in line of sight If this does not help you in correcting the malfunction, then I apologize for the trouble

That’s good news if the ping works one way at least!
Maybe it’s just a firewall issue… could you try this:

  • In the desktop, click on check firewall
  • Click restart
  • After the restart, click apply

Can you connect now?

If that’s not the case, could you temporarily disable your firewall then try to connect?

With the firewall turned off, everything worked.
Tried adding inbound and outbound rules for the program in the firewall, but it didn’t work.

Just to be sure, have you tried the automatic procedure inside the app? Or is the admin prompt too worrisome?

If you want to add specific rules, you should only need to add inbound rules for TCP and UDP on port 59100.

Automatic addition did not fix the problem. After adding port 59100 manual connection worked, although not stable