Linux App Crash

Hi! When I try to launch the app, an error is written.

OS: OpenSUSE Tumbleweed
Path: /opt/AudioRelay/

Error dump: AudioRelay OpenSUSE Crash -

Also, can you build a .rpm version too? Thanks!

Same on Manjaro 21.6 Pavho ^)
I just download .tar.xz unpacked and tried to run … and it is crashed … same as yours …

Hi, thanks for the report.

I’ve updated the lib which could cause the issue.
Could you please test both versions and tell me which one works or not for you?

With PulseAudio


Without PulseAudio


(notifying @Alex_Zaslavskis too)

You mislinked audiorelay-0.22.2.deb and audiorelay-0.22.2.tar.gz to their no pulse counterparts.

Fixed, thanks. :slight_smile:

@ArminC, @Alex_Zaslavskis
I could reproduce the error when I messed with PipeWire. The crashed happened when no pulse audio service was running.
Just to be sure, does the pactl info command do anything on your end?

@Asapha Right now, strangely, all versions are launching (0.22.1; 0.22.2; 0.22.2-no-pulse). But, there is a problem: I can’t hear anything. At all.

Also, I saw another minor problem while playing with the outputs. There is a HD-Audio Generic: ALC269VC Analog (hw:1,0) output which if selected, gives an exception error box.

All the required logs:

@ArminC Thanks for the logs. The next version should show slightly more info on the error.

As for the lack of sound, I don’t see anything wrong in the logs. :thinking:

On my end, I need to either select Monitor of XXX in AudioRelay

Or select default in AudioRelay and Monitor of XXX in Volume Control -> Recording

Could you please verify that AudioRelay appears as recording in pavucontrol / PulseAudio volume?
And that the volume indicator is moving too?

Right, got it. So, from my usage these are the variants:

  1. Monitor of Built-in selected in pavucontrol in case of default (ALSA) in AudioRelay
  2. default (PulseAudio) in AudioRelay with Monitor of Built-in - pavucontrol
  3. Monitor of Built-in - AudioRelay

But there is a catch. If I want to relay the audio just to my phone, the PC’s audio (in this case, speakers in the settings) needs to be unmuted and my computer’s speakers are outputing in the same time as my phone. What should I do? Thanks!

You need to create a virtual sink!

To quickly test it, run:

pactl load-module module-null-sink \
	sink_name=audiorelay-fake-speakers \

Then select Fake-Speakers as your default output device or as an output for a single application:

Don’t forget to select Monitor of Fake-Speakers in either AudioRelay or Volume control.

Keeping the fake device after a reboot

Add this line at the end of /etc/pulse/ file:

pactl load-module module-null-sink sink_name=audiorelay-fake-speakers sink_properties=device.description=Fake-Speakers

Let me know if this works OK for you. :smiley:
(I’ll need to add these instructions here. )

Yeah, that should do it. Perfect! However, can’t the app do this in a automatically way if set so in a future version?